[Résolu]Panne charge Mia 8kwh>chgt BMS master

Forum dédié aux véhicules électriques 100% fabriqués en France de ce constructeur.

Modérateurs : Remdo, man3515, moulino51

Avatar du membre
vehiculeselectriques
Fondateur Administrateur
Messages : 9418
Enregistré le : lun. 06 09 , 2004 20:11
Mes véhicules : Saxo lifepo4, Berlingo, Kangoo RE, Italvel EVolution...
Localisation : FR-25-BESANCON
Contact :

Re: Panne au démarrage de la charge Mia 8 kw

Message par vehiculeselectriques » mer. 14 03 , 2018 20:14

ce genre de condo est à grande durée de vie et gonfle très rarement :wink:
il faudrait tester la carte BMS...
"Rien au monde ne peut faire mieux que la persévérance...
L'expression "persévérer" a résolu et résoudra toujours les problèmes de la race humaine."
Calvin Coolidge

BEL44
Messages : 160
Enregistré le : lun. 26 06 , 2017 14:08
Mes véhicules : Bateau élec, Mia 10 KWH, Scoot'élec lith, Simplicity Solaire
Localisation : NANTES 44
Contact :

Re: Panne au démarrage de la charge Mia 8 kw

Message par BEL44 » mer. 14 03 , 2018 20:27

voilà, j'en ai trouvé un, je l'ai commandé, je verrais bien si il fonctionne à l'identique, en espérant qu'il est le programme en mémoire, et la même version.

autrement, y a-t--il quelqu'un qui arrive à se connecter au bms par le can bus ?

j'ai le logiciel, mais mes premiers tests impossibles.

Avatar du membre
ghia
Messages : 235
Enregistré le : mar. 22 11 , 2016 18:28
Mes véhicules : MiAmore 12kWh
Localisation : Belgium 3040

Re: Panne au démarrage de la charge Mia 8 kWh

Message par ghia » jeu. 15 03 , 2018 1:13

J'ai réussit de connecter au OBD et de suivre les communications du bus CAN avec une connecteur OBD - Bluetooth simple.
La, il-y-a des messages qui viennent du BMS comme celles avec id 0x620 à 0x625, 0x619, 0x7A0 et 0x7A1.
En message 0x080, il-y-a bit 0 qui indique que le BMS est présente.

Il-y-a message 0x262, qui est prévu pour envoyer des choses de l'appareil diagnostique vers le BMS, mais le fichier ne définie pas les data. La réponse du BMS vient après avec message 0x662. (Je n'essayerai pas ces messages sans savoir les détails.)

Pendant certaines opérations, le BMS est active et certaines messages peuvent passer. L'extrait était pendant chargement.
Salutations, Gerard

BEL44
Messages : 160
Enregistré le : lun. 26 06 , 2017 14:08
Mes véhicules : Bateau élec, Mia 10 KWH, Scoot'élec lith, Simplicity Solaire
Localisation : NANTES 44
Contact :

Re: Panne au démarrage de la charge Mia 8 kw

Message par BEL44 » jeu. 15 03 , 2018 9:01

Le logiciel que j'ai est prévu pour les 24 cellules, voir copie jointe, les paramétrages sont simples, la difficulté c'est la connexion au can bus, pour l'instant impossible de me connecter, mais je persiste, auriez-vous une ID ? :)
Vous n’avez pas les permissions nécessaires pour voir les fichiers joints à ce message.

BEL44
Messages : 160
Enregistré le : lun. 26 06 , 2017 14:08
Mes véhicules : Bateau élec, Mia 10 KWH, Scoot'élec lith, Simplicity Solaire
Localisation : NANTES 44
Contact :

Re: Panne au démarrage de la charge Mia 8 kw

Message par BEL44 » jeu. 15 03 , 2018 9:12

Autrement le moyen le plus simple, mais le plus coûteux, avec le bon code d'entrée car les Mia sont protégés et non en open source, :oops: il faudrait avoir ce testeur aux alentours de 1000 € :

http://www.hellotrade.com/dsa-daten-und ... rface.html

Avec ce type de matériel, nous pouvons accéder au BMS et à toute la configuration du véhicule avec la possibilité de la modifier.

Avatar du membre
ghia
Messages : 235
Enregistré le : mar. 22 11 , 2016 18:28
Mes véhicules : MiAmore 12kWh
Localisation : Belgium 3040

Re: Panne au démarrage de la charge Mia 8 kWh

Message par ghia » ven. 16 03 , 2018 0:44

BEL44 a écrit :Autrement le moyen le plus simple, mais le plus coûteux, avec le bon code d'entrée car les Mia sont protégés et non en open source, :oops: il faudrait avoir ce testeur aux alentours de 1000 € :

http://www.hellotrade.com/dsa-daten-und ... rface.html

Avec ce type de matériel, nous pouvons accéder au BMS et à toute la configuration du véhicule avec la possibilité de la modifier.
Non, DSA ne vend pas au particuliers. Et si vous trouvez quand-même une interface dans l'internet, c'est probablement une pour une autre marque comme Fisker.
Salutations, Gerard

Avatar du membre
ghia
Messages : 235
Enregistré le : mar. 22 11 , 2016 18:28
Mes véhicules : MiAmore 12kWh
Localisation : Belgium 3040

Re: Panne au démarrage de la charge Mia 8 kWh

Message par ghia » ven. 16 03 , 2018 0:45

BEL44 a écrit :Le logiciel que j'ai est prévu pour les 24 cellules, voir copie jointe, les paramétrages sont simples, la difficulté c'est la connexion au can bus, pour l'instant impossible de me connecter, mais je persiste, auriez-vous une ID ? :)
Je ne sais pas vous dire plus sans savoir quoi vous êtes en train d'essayer. Une ID dans le sens de PID ou DTC n'existe pas chez la Mia.
Salutations, Gerard

BEL44
Messages : 160
Enregistré le : lun. 26 06 , 2017 14:08
Mes véhicules : Bateau élec, Mia 10 KWH, Scoot'élec lith, Simplicity Solaire
Localisation : NANTES 44
Contact :

Re: Panne au démarrage de la charge Mia 8 kw

Message par BEL44 » ven. 16 03 , 2018 8:05

Tu me coupe le moral ! tu es en train de me dire que c'est tout simplement impossible !
Je m'en doutais !
Le Secret industriels persiste sur les Mia malgré sa désintégration.
Nos Mia sont donc vouées à la déchetterie ! :?

Avatar du membre
ghia
Messages : 235
Enregistré le : mar. 22 11 , 2016 18:28
Mes véhicules : MiAmore 12kWh
Localisation : Belgium 3040

Re: Panne au démarrage de la charge Mia 8 kWh

Message par ghia » ven. 16 03 , 2018 12:45

Ça va être dur! Oui, mais il-y-a aussi des possibilités, qui nécessite la coopération de quelqu’un qui a une valise diagnostique. On peut recorder toutes la trafic CAN pendant une session avec la valise et essayer de apprendre la connexion avec l'interne de différentes ECU.

Nous, on a de la chance avec notre Mia et déjà beaucoup de documentation dans l'ouverte, mais en général toutes est une grande top secret industrielle. Aussi au part du constructeurs du modules diverses, qui ne lâchent rien, même si la modèle est déjà obsolète.

(Même vous ne répondez pas au quoi exactement que vous êtes en train de essayer.)
Salutations, Gerard

BEL44
Messages : 160
Enregistré le : lun. 26 06 , 2017 14:08
Mes véhicules : Bateau élec, Mia 10 KWH, Scoot'élec lith, Simplicity Solaire
Localisation : NANTES 44
Contact :

Re: Panne au démarrage de la charge Mia 8 kw

Message par BEL44 » ven. 16 03 , 2018 13:19

Je suis en cours d'essai de me brancher au bus can pour me connecter directement au BMS avec le logiciel de contrôle de la batterie photo précédente.
Demain, je reçois le nouveau BMS master, et je le teste sur le véhicule.
J'utilise pour me connecter l'appareil :
Vous n’avez pas les permissions nécessaires pour voir les fichiers joints à ce message.

Avatar du membre
ghia
Messages : 235
Enregistré le : mar. 22 11 , 2016 18:28
Mes véhicules : MiAmore 12kWh
Localisation : Belgium 3040

Re: Panne au démarrage de la charge Mia 8 kw

Message par ghia » ven. 16 03 , 2018 16:28

Je me demande si cette interface est appropriée pour connecter. Ça n'est pas claire pour moi si c'est possible de connecter dans une mode 'raw' au CANbus, sans que les données sont interprétée par une ou autre OBD protocole et quoi qui passe avec des message non sollicitées.
Salutations, Gerard

BEL44
Messages : 160
Enregistré le : lun. 26 06 , 2017 14:08
Mes véhicules : Bateau élec, Mia 10 KWH, Scoot'élec lith, Simplicity Solaire
Localisation : NANTES 44
Contact :

Re: Panne au démarrage de la charge Mia 8 kw

Message par BEL44 » ven. 16 03 , 2018 17:34

c'est uniquement pour se connecter au BMS, cette interface n'a pas vocation à se connecter au véhicule. Le logiciel traite uniquement la batterie.

BEL44
Messages : 160
Enregistré le : lun. 26 06 , 2017 14:08
Mes véhicules : Bateau élec, Mia 10 KWH, Scoot'élec lith, Simplicity Solaire
Localisation : NANTES 44
Contact :

Re: Panne au démarrage de la charge Mia 8 kw

Message par BEL44 » sam. 17 03 , 2018 18:16

Afin de conclure sur le sujet et faire une synthèse de la réparation, le titre ferait penser à un problème de charge, après diagnostic du chargeur, de la connectique et du câblage, le chargeur est parfaitement fonctionnel.

Le problème provenait tout simplement du BMS master défectueux à l'intérieur de la batterie, qui bloquait la charge.

en attente de la prochaine panne ! :lol:

Répondre

Retourner vers « mia electric »